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This document is an adapted transcription of the tutorial video (YouTube channel “EO College”) 

entitled « ESA Echoes in Space - Hazard: Flood mapping with Sentinel-1 (ESA EO College)” from 5 

November 2017 where Dr. Chris Stewart explains how to derive a flood map from Sentinel-1 images, 

using SNAP. The transcription is augmented with additional illustrations and comments. 
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1. Objective (video timing: 0 min 00 sec) 
 To map flooded area with Sentinel-1 data by a simple technique: using an image before the 

flood (called the “Archive image”) and an image during the flood (called the “Crisis image”) 

to distinguish between: 

o Flooded area 

o Permanent water bodies 

2. Technical description of the 2 Sentinel-1 images used  

 2 Sentinel-1 images over a part of Myanmar, with the following technical features: 

o Remarque 

 The filename conventions of Sentinel products are available here : 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/naming-

conventions  

o Pass ascending 

 Part of the satellite orbit trajectory going from South to North poles, 

information available in the Metadata, confer Figure 6 page 9 

o Mode VV 

 Polarization mode of the SAR signal: Vertical emitted by the sensor and 

Vertically received by the sensor 

o Sensor mode IW 

 Interferometric Wide acquisition mode (Figure 1): confer here for more 

information: https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-

sar/acquisition-modes 

o Product type GRD 

 Ground Range Detected 

 More information here: 

https://sentinel.esa.int/web/sentinel/missions/sentinel-1/data-products 

 Remarque: in GRDH (confer image filename), the H stands for the resolution 

class, which is High (H) in this case) 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/naming-conventions
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/naming-conventions
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes
https://sentinel.esa.int/web/sentinel/missions/sentinel-1/data-products
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Figure 1 : Sentinel-1 Product Modes (Source : https://sentinel.esa.int/web/sentinel/user-
guides/sentinel-1-sar/acquisition-modes) 

  

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes
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3. Download of the 2 Sentinel-1 images (not in the video) 

 Go to the “Copernicus Open Access Hub” https://scihub.copernicus.eu/dhus/#/home 

 Create an account and then log in 

 Search and download the 2 images 

o You can use the image name (confer below) without “.zip” extension in the search 

menu to easily find the images, one by one (Figure 2) 

o The 2 images used are (table below): 

 

Image timing Date Image filename 

Archive image before the flood 2015 03 20 S1A_IW_GRDH_1SSV_20150320T114745_201503
20T114810_005115_0066FA_82D7.zip 

Crisis image during the flood 2015 09 04 S1A_IW_GRDH_1SSV_20150904T114747_201509
04T114812_007565_00A772_B9FD.zip 

 

 

Figure 2 : Copernicus Open Access Hub with one of the 2 Sentinel-1 images identified over 
Myanmar 

  

https://scihub.copernicus.eu/dhus/#/home
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4. SNAP software - Download and installation (not in the 

video) 

 You can download the free SNAP software here:  

o https://step.esa.int/main/download/snap-download/ 

o Choose the « Sentinel Toolboxes » or “All Toolboxes”  in the table and the download 

adapted to your operating system 

 Install SNAP on your computer and make the updates after installation 

 

Figure 3 : Outlook of the SNAP (STEP) software download web page 

 

  

https://step.esa.int/main/download/snap-download/
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5. Opening of the 2 Sentinel-1 images in SNAP (video 

timing: 0 min 30 sec) 

 Simply drag and drop the zip images to the “Product Explorer” tab of SNAP (there is no 

need to unzip the images!)  

 In the “World View” tab, you can see that the images are over a part of Myanmar 

 In the “Product Explorer” tab, expand for each image the sub-folder “Bands > 

Amplitude_VV” and double-clic on “Amplitude_VV” which will open the images in the 

viewer 

o Open first the Archive image  in viewer 1 

o Open then the Crisis image  in viewer 2 

 Remarque: notice that there are 2 bands per image, Amplitude and Intensity. Definition: 

o Amplitude_VV image 

 “A SAR signal contains amplitude and phase information. Amplitude is the 

strength of the radar response” (source: 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/product-

overview/interferometry).  

 “Measure of the strength of a signal, and in particular the strength or height 

of an electromagnetic wave (units of voltage).” (source: 

https://earth.esa.int/handbooks/asar/CNTR5-2.html)  

o Intensity_VV image 

 Intensity = Amplitude_VV * Amplitude_VV 

 Observe the images (Figure 5): 

o You can zoom or move into the images by using the mouse wheel or the panning tool 

 
o In the crisis image: 

 Flooded area: appears darker because of a low backscatter due to specular 

reflection over the smooth water surfaces: the signal get reflected away 

from the sensor.  

 The surrounding areas: are much rougher and look brighter. 

 Images distortion is visible in the mountain areas of the image due to the 

layover and foreshortening effects (Figure 4) 

  

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/product-overview/interferometry
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/product-overview/interferometry
https://earth.esa.int/handbooks/asar/CNTR5-2.html
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Foreshortening Layover 

 
 

 
 

  
Figure 4 : Illustration of the Foreshortening and Layover effects: geometric distortions in 
mountainous regions (Source: https://earth.esa.int/web/guest/missions/esa-operational-eo-
missions/ers/instruments/sar/applications/radar-courses/content-2/-
/asset_publisher/qIBc6NYRXfnG/content/radar-course-2-slant-range-ground-range#sixteen) 

6. Main steps of the workflow described in this document 

(video timing: 2 min 18 sec) 

 Make a spatial subset of the images around the river over the flooded areas 

 Apply a “multilooking” in order to reduce the speckle, and this also reduces the dimension of 

the images and speed up the processing time 

 Apply a calibration which is essential to compare 2 images: to go from Digital Numbers (DN) 

to a physical quantity which is in this case “sigma0 backscatter” 

 Apply a terrain correction to project the images onto a map system and also to correct for 

the distortions due to the terrain 

 Combine the 2 images in a RGB composite in order to distinguish between flooded areas and 

permanent water bodies 

https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-2/-/asset_publisher/qIBc6NYRXfnG/content/radar-course-2-slant-range-ground-range#sixteen
https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-2/-/asset_publisher/qIBc6NYRXfnG/content/radar-course-2-slant-range-ground-range#sixteen
https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-2/-/asset_publisher/qIBc6NYRXfnG/content/radar-course-2-slant-range-ground-range#sixteen
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7. Visual analysis of the 2 images side by side (video 

timing: 3 min 09 sec) 

 Menu: Window > Tile evenly 

 You should synchronize the 2 windows (and optionally the mouse pointer) by using, in the 

“Navigation” tab of the bottom left panel, the 2 related tools button 

 

Figure 5 : The archive/normal situation (left) and crisis/flood (right) Sentinel-1 images over 
Myanmar displayed evenly in SNAP interface  
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8. Analysis of images Metadata (video timing: 3 min 15 

sec) 

 In the “Product Explorer” tab, open the subfolders “Metadata > Abstracted Metadata” and 

double-click on it to open it (Figure 6). You can see that: 

o Both images were acquired in the same geometry which is essential for flood 

mapping:  

 PASS = ASCENDING: satellite ascending 

 incidence_near (30.9°) & incidence _far (46.1°): same incidence angle  

o PRODUCT_TYPE = GRD 

o ACQUISITION_MODE = IW 

o mds1_tx_rx_polar = VV (and no info for mds2…, mds3…, mds4…) 

o etc 

 There is a shift in Azimuth (in the North-South direction, the 2 images do not perfectly cover 

the same area) but this is not a problem 

 To know what image is open in what tab: look at the number  between [] both in the 

“Product Explorer” tab and in the visualization windows 

 

Figure 6 : Outlook of some Abstracted Metadata of one Sentinel-1 image. The […] means that some 
metadata are skipped from this illustration 
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9. Spatial subset of the images, on an area common to the 

2 images, where the main floods occur (video timing: 3 

min 53 sec) 

 Identify in the navigation tab an area which is common to both images: zoom and pan in 

order to display that common area in the viewers (Figure 5) 

 Click, in the geographical interface, on the image you want to process in order to 

select/active it, in order to use this image current extent for the spatial subset 

 Menu: Raster > Subset (video timing: 4 min 03 sec) 

o The subset corresponds to the extent of the viewer. You can visually check that in the 

tool interface 

o Click OK 

o Repeat the operation for both images 

 

Figure 7 : Spatial subset of Sentinel-1 image 

 The outputs appear automatically in the “Product Explorer” as virtual files/image.  

 They then have to be saved to real file (real image) with either 

o Select the file in the “Product Explorer” tab, then File > Save Product > 

o or Right click on the file in the “Product Explorer” tab, then > Save Product 

 Say Yes to BEAM-DIMAP format 

 Give a Shorter filename than the original long filename: 

o Keep the most important information: date product, processing level etc 

o Remove the automatically created prefix (“subset_0_of_”) 
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o And give also a suffix “crop” (or “subset”) in order to easily identify the output image 

as the subset image  

o Select your working directory where to store the output images  

o The output filenames of the 2 images are, in the video: 

 S1A_IW_GRDH_1SSV_20150320T114745_crop.zip 

 S1A_IW_GRDH_1SSV_20150904T114747_crop.zip 

o Click on Save 

 The 2 subseted images are now present in you working directory 

 

10. Intermediate steps: closing/opening images (video 

timing: 6 min 00 sec) 

 Close all images in the “Product explorer” tab 

o Right click in the left panel > Close All Products 

 Open only the 2 subset images in SNAP  

o Drag and drop them to the “Product explorer” tab from your working directory 
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11. Multilooking (video timing: 6 min 30 sec) 

 Purpose: to reduce the speckle and reduce the dimension of the image to speed up the 

processing time. This will also result in a loss of accuracy (spatial resolution) but this is not a 

problem in this particular case because the flooded area is large and we are not particularly 

interested in having a high resolution flood map. 

 Menu: Radar > SAR Utilities > Multilooking (this directory is a bit different than in the 

tutorial video due to different SNAP software versions) (Figure 8) 

o In the “I/O Parameters” window 

 Keep default added suffix “ML” in the output filename 

 Select your working directory as output directory 

o In the “Processing Parameters” window 

 Set the Number of Range/Azimuth Looks to 3 by 3 

o Click on Run 

o Repeat the process for the other image 

  

Figure 8 : Parametrization of the Multilooking tool of SNAP 

  (Remarque: after this operation, the subseted images cannot be synchronized well with the 

original images because a size reduction has been applied, reason why all products were 

closed in the previous “intermediate steps”) 
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12. Radiometric Calibration (video timing: 7 min 35 sec) 

 Calibration is essential to enable the comparison of the 2 images 

 Calibration transforms Digital Numbers (DN) to a physical quantity which is in this case 

“sigma0 backscatter” 

 Definition:  

o “Backscatter: […] The normalised measure of the radar return from a distributed 

target is called the backscatter coefficient, or sigma nought , and is defined as per 

unit area on the ground.”  

o “Sigma Nought: Scattering coefficient, or the conventional measure of the strength 

of radar signals reflected by a distributed scatterer, usually expressed in dB. It is a 

normalised dimensionless number, comparing the strength observed to that 

expected from an area of one square meter.” 

o (Source: https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-

sar/definitions) 

 Menu: Radar > Radiometric > Calibrate (Figure 9) 

o In the “I/O Parameters” window 

 Select the “ML” images as input 

 Keep default added suffix “Cal” in the output filename 

 Select your working directory as output directory 

o In the “Processing Parameters” window 

 Check “Output sigma0 band” (= ratio instant/receive backscatter per unit 

area in ground range)  

o Click on Run 

o Repeat the process for the other image  

  

Figure 9 : Parametrization of the Radar Radiometric Calibration tool of SNAP 

  

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/definitions
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/definitions
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13. Intermediate steps: visualization (video timing: 8 min 

22 sec) 

 Visualize the 2 sigma0 images in the viewer 

o Double-click on each calibrated images in the “Product Explorer” window to open 

them in the SNAP viewer (“Sigma0_VV” is the name of the calibrated images) 

o Menu: Window > Tile Evenly to display the images side by side 

 

Figure 10 : Subseted, Multilooked and Radiometrically Calibrated (Sigma0_VV) Sentinel-1 images 
displayed side by side 

 Many pixels are quite dark 

 Select the flood image in the viewer 

 Go to the Colour Manipulation window (bottom left panel):  

o Most of the pixels have low backscatter value 

o Few pixels have very high value 

 Convert values from linear scale to non-linear logarithmic scale decibel (dB) to get a better 

visualization and an histogram easier to manipulate  

o Right click on the band to convert (Sigma0_VV) > Linear to/from dB > Yes to create 

a new virtual band 

o Repeat that for the other image 

 Open the 2 converted images in dB by double-clicking on them  
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 Menu: Window > Tile evenly (you can rearrange the windows if you want) (Figure 11) 

 In dB, there is a much better distinction between land and water pixels 

 We can see 2 peaks in the dB images histograms: 

o 1 small low values peak for pixels over water 

o 1 big high values peak for land pixel 

 Close all images from the viewer but keep the images in the “Product Explorer” tab 

 

Figure 11 : Comparison of the Sigma0_VV Sentinel-1 images before (above) and after (below) the 
“Linear to/from dB” image histogram conversion for the archive (left) and flood (right) images 
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14. Terrain Correction (video timing: 10 min 22 sec) 

 Purpose: 

o To project the image into a coordinates system, and  

o To correct for distortion due to the mountainous terrain 

 Menu: Radar > Geometric > Terrain correction > Range-Doppler Terrain Correction > all 

parameters by default > Run (default suffix = TC) (Figure 12) 

o In the “I/O Parameters” window 

 Select the “ML_cal” images as input 

 Keep default added suffix “TC” in the output filename 

 Select your working directory as output directory 

o In the “Processing Parameters” window 

 Keep all default parameters (WGS84 map projection) 

o Click on Run 

o Repeat the process for the other image 

  

Figure 12 : Parametrization of the Range Doppler Terrain Correction tool of SNAP 
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15. Visualization of the terrain corrected images (video 

timing: 11 min 32 sec) 

 Convert the “TC” bands to dB (confer method explained above) 

 Convert the virtual created dB bands to real file 

o Right click on the dB band > convert band 

 Save to dB band to file 

o Select the dB band > Main menu File > Save Product: this saves the dB band to the 

image 

 Visualize the dB terrain corrected bands 

o The image has been projected into a coordinate system: the TC image orientation 

has changed! (Figure 13) 

o In order to be able to compare the non TC an TC images visually, you have to 

unsynchronize the views with the dedicated button in the “Navigation” tab (bottom 

left panel), and then open each image in a window that you can display side by side. 

You will maybe have to unzoom a lot from one of the two images to adjust the 

visualization.  

o There is no more distortion in the mountain area (Figure 14) 

o (You could also do a contrast stretch with the “Color Manipulation” tab (bottom left 

panel) to highlight only the pixels over the land) 

 

Figure 13 : Comparison of the archive Sentinel-1 images before (left) and after (right) the Terrain 
Correction: change of the image orientation due to the projection into a coordinate system  
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Figure 14 : Comparison of the archive Sentinel-1 images before (left) and after (right) the Terrain 
Correction for a mountainous area: the geometric distortion have been corrected 
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16. Combination of the Archive and Crisis images to 

produce a RGB composite of the flooded area, 

preliminary step: images stack (video timing: 13 min 25 

sec) 

 Purpose of the RGB composite: to enable the distinction of permanent water bodies and 

flooded areas.  

 Remarque: The RGB composite is effectively produced in the section 18 page 22. 

 Application of a stack by simply using the products geolocation 

o Menu: Radar > Coregistraction > Stack Tools > Crate Stack tabs 

o In window “1-ProductSet-Reader” 

 Click on the “Add opened” button > and keep only the TC file by removing 

unwanted files or open only the 2 images of interest with the Add button 

o In window “2-CreateStack” 

 Choose “Product Geolocation” for “Initial offset method” 

 ([…Remarque: for interferometry, a much more precise geolocalization 

method should be used…]) 

o In window “3-Write” 

 Remove part of the filename which is not common to both images: the 

acquisition dates 

o Select Run 

o Close window 
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Figure 15 : Parametrization of the « Create Stack » tool of SNAP 
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17. Overlay of the stacked images for visual comparison of 

the 2 images (optional) 

  (This step is not really necessary in the general workflow) (video timing: 15 min 33 sec) 

o We get the stack image file which is one single image file that contains 4 layers 

coming from the 2 archive and crisis images in the “Bands” subfolder 

o Open the 2 images in dB  

o Apply a contrast stretch with the histogram focused on the higher pixel values peak 

o To overlay the 2 images in the same viewer: 

 Click on the Archive image in the viewer to select it 

 Go to “Layer manager” (right panel) > + icon >Image of Band / Tie-point 

Grid > Next > overlay the 2nd image in dB (Crisis image) on the first one > 

Finish 

o You can then compare both images by checking unchecking one image in the right 

panel “Layer manager” or by playing with the transparency slider at the bottom of 

the “Layer manager” 

 

Figure 16 : Overlay of the 2 TC dB images in 1 viewer and use of the « Layer Manager » panel 
allowing to check/uncheck one of the 2 overlaid layers as well as applying a transparency in order 
to compare the 2 images 
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18. RGB composite image (video timing: 16 min 50 sec) 

 Purpose: to distinguish between flooded area and permanent water bodies 

 Select the name of the stack file in the “Product Explorer” window 

 Menu: Window > Open RGB window 

o Red band: select Archive image 

o Green and Blue bands: select Crisis image 

o Click OK 

o View the flood map (Figure 17) 

 

 

Figure 17 : RGB composite using, in the Red band, the Archive image, and in the Green and Blue 
bands, the Crisis image 
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19. Interpretation of the RGB composite (video timing: 17 

min 28 sec) 

 The RGB composite image is presented in Figure 17. 

 Flooded areas 

o Appears in red because, given the selected RGB composite above, where floods 

occur,  

 the Archive image (in the red channel) has higher backscatter (no flood) than  

 the Crisis image (in the green and blue channel) (low backscatter for flooded 

areas)  

o So for flooded areas, there is a high value in the red channel and low value in the 

green and blue channels. 

 Non-flooded land 

o Appears in tones of gray as there is approximately the same backscatter for the 2 

images (no difference), and that that “same” information is associated to all 3 

channels 

 Permanent water bodies 

o Appears as uniform dark areas as there is a low backscatter values for both Archive 

and Crisis images, both associated to the 3 RGB channels   

 Some part of the land are cyan 

o This translates a higher response in the green and blue channels corresponding to 

the crisis image, than in the Archive image. This may be due to particular ground 

cover which is not related to flood. 

20. Exportation of the RGB composite of the flood map in 

another format and visualization of the result in 

GOOGLE EARTH PRO (video timing: 19 min 22 sec)  

 (Menu: File > Export > Geotiff). This step is not done in the video. This is just an example.  

 The visualization of the RGB composite of the flood map in GOOGLE EARTH PRO is 

presented in Figure 18. 

 Right click on the view > Export View as Google Earth KMZ 

o Record the output in your working directory and call it for example “Flood” 

o Browse to you working directory where the file “Flood.kmz” has been saved 

o If you have Google Earth Pro installed on your computer, you can simply double-click 

on this file and it will automatically open in Google Earth at the right position.  

o (If you do not have Google Earth Pro installed on your computer, you can get it here 

for example: https://www.google.com/intl/fr_ALL/earth/versions/ (bottom of page)) 

o You can then compare the flood map with Google Earth Pro imagery and also check 

the registration (georeferencing) of the flood map, which is good in this case (by 

deselecting the layer or playing with the layer transparency). In Google Earth Pro you 

https://www.google.com/intl/fr_ALL/earth/versions/
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can also apply an oblique view and ask for a 3D rendering of the natural relief (that 

can be exaggerated: menu Tools > Options > 3D View > Relief > and set the elevation 

factor to 3). 

 

Figure 18 : Outlook of the RGB composite flood map overlaid in Google Earth Pro with an oblique 
3D view 
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