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”Without sufficient observations,
useful prediction will likely never be
possible.”



”Models will evolve and improve,
but, without data, will be untestable,
and observations not taken today are
lost forever.”

C. Wunsch et al. (2010) PNAS



Why in situ data?

1. Model initialisation

2. Model validation models are idealisation of the reality

3. Data assimilation

4. Satellite cannot see below the surface

”Without data assimilation, any attempt to produce reliable forecasts
is almost certain to end in failure.”

http://www.metoffice.gov.uk/learning/science/first-steps
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The ocean is complex

Many processes

and many scales
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A multi-platform approach is essential

”We must be able to document conditions and measure fluxes within
the volume of the ocean, simultaneously and in real time, over many
scales of time and space, regardless of the depth, energy, mobility, or
complexity of the processes involved.”

Delaney and Bargas (2009)



A multi-platform approach is essential

Credit: Global Ocean Observing System Office (IOC-GOOS)



A multi-platform approach is essential

Balearic Islands Coastal Ocean Observing and Forecasting System
www.socib.es

www.socib.es


A multi-platform approach is essential

Coastal Observing System for Northern and Arctic Seas
http://codm.hzg.de/codm/

http://codm.hzg.de/codm/


Types of in situ data

Research Vessel temperature, salinity, currents, oxygen, . . .

Feature type: trajectory of profiles for CTD
trajectory for thermosalinograph



Types of in situ data

Coastal HF Radar Current speed and direction

Feature type: grid



Types of in situ data

Glider Temperature, salinity, currents, chlorophyll, . . .

Feature type: trajectory



Types of in situ data

Drifting buoys and profilers Temperature, salinity, currents, . . .

Feature type: trajectory and trajectory of profiles



Types of in situ data

Fixed stations Sea-level, weather/water column variables

Feature type: time series



Data quality



Data quality

Example: platform velocity (drifter) in meters per second



Why data are not always good?
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Why data are not always good?



QC processing

1. variety of instruments
→ different precision, accuracy and methods

2. a given variable should undergo common QC
with testing depending on the instrument/platform

3. needs for standards indicating reliability

4. needs for easily found documentation of the test procedures

5. original values must be preserved

6. problems found by users → reported back to the provider



Quality flags are stored in the netCDF files

Example: temperature from a profiler:
. . .
f l o a t TEMP( TIME , DEPTH) ;
TEMP: long name = ” Sea t e m p e r a t u r e ” ;
TEMP: s t a n d a r d n a m e = ” s e a w a t e r t e m p e r a t u r e ” ;
TEMP: u n i t s = ” d e g r e e C e l s i u s ” ;
TEMP: F i l l V a l u e = 9 .96921 e +36 f ;

b y t e TEMP QC( TIME , DEPTH) ;
TEMP QC : long name = ” q u a l i t y f l a g ” ;
TEMP QC : c o n v e n t i o n s = ” O c e a n S i t e s r e f e r e n c e t a b l e 2 ” ;
TEMP QC : F i l l V a l u e = −128b ;
TEMP QC : v a l i d m i n = 0b ;
TEMP QC : v a l i d m a x = 9b ;
TEMP QC : f l a g v a l u e s = 0b , 1b , 2b , 3b , 4b , 5b , 6b , 7b , 8b , 9b ;
TEMP QC : f l a g m e a n i n g s = ” n o q c p e r f o r m e d g o o d d a t a p r o b a b l y g o o d d a t a
b a d d a t a t h a t a r e p o t e n t i a l l y c o r r e c t a b l e b a d d a t a v a l u e c h a n g e d
n o t u s e d n o m i n a l v a l u e i n t e r p o l a t e d v a l u e m i s s i n g v a l u e ” ;

. . .



Quality flag meaning

QF value Meaning

0 no QC performed
1 good data
2 probably good
3 bad data that are potentially correctable
4 bad data
5 value changed
7 nominal value
8 interpolated value
9 missing value

In most situations: only use data with flag=1
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Real-time vs. delayed mode quality control

Real-time QC cannot detect all the anomalies

▶ Real-time QC automatic tests thresholds are a compromise
between:

1. letting bad data going through and
2. stopping good data

▶ Delayed mode QC implies visual inspection by an operator



Tests applied on Argo vertical profiles

▶ Deepest Pressure Test

▶ Platform Identification
▶ Impossible Date Test
▶ Impossible Location Test
▶ Position on Land Test
▶ Impossible Speed Test
▶ Global Range Test
▶ Regional Range Test
▶ Pressure Increasing Test
▶ Spike Test

▶ Gradient Test
▶ Digit Rollover Test
▶ Stuck Value Test
▶ Density Inversion
▶ Grey List
▶ Gross salinity or temperature

sensor drift
▶ Frozen profile
▶ Visual QC

More details: doi:10.13155/33951

http://dx.doi.org/10.13155/33951
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Summary
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2. Quality flags assigned to the measurements

3. In situ data are essential for numerical model

4. In situ observations are scarce
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Training material

ipython notebooks distributed in github
https://github.com/ctroupin/OceanData NoteBooks

https://github.com/ctroupin/OceanData_NoteBooks


Why ipython notebooks?

▶ User-friendly

▶ Free, easy to write, easy to read

▶ Code and results visible online via http://nbviewer.ipython.org

http://nbviewer.ipython.org


Why github?

▶ Public access, easy to download

▶ Collaborative development

▶ Bug tracking, feature request, wikis, . . .



How does it looks like?



How to get the
data?



Getting CORA dataset

http://marine.copernicus.eu: click on ONLINE CATALOGUE

http://marine.copernicus.eu


Getting CORA dataset

Select ”Global Ocean” and type ”CORA” in search box



Getting CORA dataset

Download product



Getting CORA dataset

Use your username & password



Getting CORA dataset

FTP access (username & password)



Getting CORA dataset

OA directory



Getting CORA dataset

data directory



Getting CORA dataset

Select year of interest



Getting CORA dataset

Select month and variable



How to work
with the data?



Quick inspection: ncdump

Home page: https://www.unidata.ucar.edu/software/netcdf/docs/netcdf/ncdump.html

What is does: text representation of a netCDF dataset (header
information, variables, . . . )

ncdump applied on a file
ncdump −h 20140628 d−OC CNR−L3−CHL−MedOC3 A 1KM−MED−DT−v02 . nc

n e t c d f \20140628 d−OC CNR−L3−CHL−MedOC3 A 1KM−MED−DT−v02 {
d i m e n s i o n s :

t ime = 1 ;
l a t = 1580 ;
l o n = 3308 ;

v a r i a b l e s :
i n t t ime ( t ime ) ;

t ime : long name = ” r e f e r e n c e t ime ” ;
t ime : s t a n d a r d n a m e = ” t ime ” ;
t ime : a x i s = ”T” ;
t ime : c a l e n d a r = ” G r e g o r i a n ” ;
t ime : u n i t s = ” s e c o n d s s i n c e 1981−01−01 0 0 : 0 0 : 0 0 ” ;

. . .
”SUBSAMP=1\n ” ,
”OUTMODE=0\n ” ,
” ” ;

}

https://www.unidata.ucar.edu/software/netcdf/docs/netcdf/ncdump.html


Ferret

Home page: http://www.ferret.noaa.gov/Ferret/

What is does: visualization and analysis environment

Ferret to get basic info on file
ctroupin@SCBD046 ˜ / Desktop $ f e r r e t c

NOAA/PMEL TMAP
FERRET v6 . 6 2
Linux ( g f o r t r a n ) 2 . 6 . 9 −8 9 . 0 . 2 0 . ELsmp − 0 7 / 0 6 / 1 3
25−Nov−15 12 :23

yes ? SET DATA 20140628 d−OC CNR−L3−CHL−MedOC3 A 1KM−MED−DT−v02 . nc
yes ? SHOW DATA

c u r r e n t l y SET d a t a s e t s :
1> 20140628 d−OC CNR−L3−CHL−MedOC3 A 1KM−MED−DT−v02 . nc ( d e f a u l t )

name t i t l e I J K L
CHL M e d i t e r r a n e a n Sea D a i l y Chlorop 1 :3308 1 :1580 . . . 1 : 1
QI Q u a l i t y Index of M e d i t e r r a n e a n 1 :3308 1 :1580 . . . 1 : 1

yes ?

http://www.ferret.noaa.gov/Ferret/


ncview

Home page: http://meteora.ucsd.edu/∼pierce/ncview home page.html

What it does: quick visualisation of 3-4D fields

http://meteora.ucsd.edu/~pierce/ncview_home_page.html


ncbrowse

Home page: http://www.epic.noaa.gov/java/ncBrowse/

What is does: interactive graphical display

http://www.epic.noaa.gov/java/ncBrowse/


Panoply

Home page: http://www.giss.nasa.gov/tools/panoply/

What is does: plot, slice, combine, overlay, . . .

http://www.giss.nasa.gov/tools/panoply/


cdo – Climate Data Operators

Home page: https://code.zmaw.de/projects/cdo

What is does: manipulate (merging, averaging) netCDF files (+other
formats)

Examples: ▶ Basic info (min, max, avg, size, . . . ):
cdo i n f o i n p u t . nc

▶ Compute standard deviation:
cdo f l d s t d i n p u t . nc o u t p u t . nc

https://code.zmaw.de/projects/cdo


NCO – netCDF Operators

Home page: http://nco.sourceforge.net/

What is does: command line operations on netCDF files

Examples: ▶ Average variable over domain:
ncwa −O −a lon , l a t i n p u t . nc o u t p u t . nc

▶ Extract subregion:
ncks −d lon , 1 3 . , 1 8 . 0 −d l a t , 3 3 . 0 , 3 6 . 0
i n p u t . nc o u t p u t . nc

http://nco.sourceforge.net/


ODV – Ocean Data View

Home page: http://odv.awi.de/en/home/

What is does: interactive exploration, analysis and visualization of
oceanographic data

Wanna know more? Click here

http://odv.awi.de/en/home/


Octave / Matlab

High-level functions to read/write data from/to a netCDF file:
http://octave.sourceforge.net/netcdf/overview.html

http://es.mathworks.com/help/matlab/network-common-data-form.html

Example with Octave
nc = n e t c d f ( ’ i n p u t . nc ’ , ’ r ’ ) ; % open n e t c d f f i l e in read−on ly

CHL = nc{ ’CHL ’ } ( : ) ; % r e t r i e v e v a r i a b l e
CHL uni t s = nc{ ’CHL ’ } . u n i t s ; % r e t r i e v e t h e a t t r i b u t e u n i t s
C H L v a l i d r a n g e = nc{ ’CHL ’ } . v a l i d r a n g e ; % r e t r i e v e t h e a t t r i b u t e v a l i d r a n g e
g l o b a l h i s t o r y = nc . h i s t o r y ; % r e t r i e v e t h e g l o b a l a t t r i b u t e h i s t o r y

http://octave.sourceforge.net/netcdf/overview.html
http://es.mathworks.com/help/matlab/network-common-data-form.html


Python

Python interface to the netCDF C library:
http://unidata.github.io/netcdf4-python/

Example with ipython
In [ 1 ] : import netCDF4
In [ 2 ] : nc = netCDF4 . D a t a s e t ( ’ 20140628 d−OC CNR−L3−CHL−MedOC3 A 1KM−MED−DT−v02 . nc ’ )
In [ 3 ] : p r i n t nc
<type ’ netCDF4 . netCDF4 . D a t a s e t ’>
r o o t group ( NETCDF3 CLASSIC d a t a model , f i l e format UNDEFINED ) :

C o n v e n t i o n s : CF−1.4
t i t l e : d a t a s e t−oc−med−ch l−modis a−l3−c h l 1 k m d a i l y−r t−v02
r e f e r e n c e s : R . S a n t o l e r i ,G . Volpe , S . Maru l lo and B . Buongiorno N a r d e l l i ( 2 0 0 8 ) ,
. . .

I n [ 4 ] : CHL = nc . v a r i a b l e s [ ’CHL ’ ] [ : ]
In [ 5 ] : nc . c l o s e ( )

Wanna know more? Click here

http://unidata.github.io/netcdf4-python/


Ocean
Data View



ODV in 3 lines

> 40000 registered users
Data analysis + visualisation
Almost every format supported



Working with ODV
on Time Series



Objective: plotting time series

Temperature at mooring Athos



Opening the netCDF file

File → Open → netcdf



Opening the netCDF file

Dimension and variables : Next



Opening the netCDF file

Variable association : Next

� Quality Control variables not visible at this stage



Opening the netCDF file

Primary variables : Next



Opening the netCDF file

Subset dimensions : Finish



Plot the time series

View → Layout template → Scatter window



Plot the time series

Í Right-click on plot:
Change X and Y variable (temperature vs. time)
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Plot the time series

Í Right-click on plot:
Change X and Y variable (temperature vs. time)

� Bad values: will be treated later



Plot the time series

Í Right-click on plot: Sample Select Criteria
→ depth range



Plot the time series

Í Right-click on plot: Sample Select Criteria
→ depth range



Plot the time series

Í Right-click on plot: Sample Select Criteria
→ depth range

� Now we have the series at 2 depth



Improve the plot

Í Right-click on plot: Properties



Improve the plot

Display Style: modify Symbols Size



Improve the plot

View → Window Layout



Improve the plot

Adapt size of the Scatter window



Improve the plot

Accept the change (Enter )



Improve the plot

Í Right-click on plot: Properties → Domain



Improve the plot

Enlarge the map domain



Improve the plot

Enlarge the map domain



Apply quality flags

Í Right-click on plot: Sample Select Criteria → depth range
Select good data only



Apply quality flags

Í Right-click on plot: Sample Select Criteria → depth range
Select good data only



Apply quality flags

Configure Window Layout to have the 2 time series
(with and without QC



Apply quality flags

Configure Window Layout to have the 2 time series
(with and without QC

� Extreme values are removed



Apply quality flags

Compare histograms:
Í Right-click on plot → Extra → Statistics



Apply quality flags

Compare histograms:
Í Right-click on plot → Extra → Statistics

� Distribution is improved



Working with ODV
on CORA data set



Objective: process CORA dataset



Opening the netCDF file

File → Open → Select the netCDF file



Opening the netCDF file

Dimension and variables : Next



Opening the netCDF file

Variable association : Next



Opening the netCDF file

Primary variables : Next



Opening the netCDF file

Subset dimensions : Finish



Opening the netCDF file

We get this window



Region selection and basic statistics

Í Right-click on image → Station Selection Criteria → Domain



Region selection and basic statistics

Í Right-click on image → Properties → Domain



Region selection and basic statistics

Í Right-click on image → Extra → Statistics



Region selection and basic statistics

Figure → X/Y Distribution

B Data scarcity and inhomogeneous distribution



Map improvement

Í Right-click on map → Properties

General: palette, colors etc



Map improvement

Í Right-click on map → Properties

Display style: increase dot size, change color



Map improvement

Í Right-click on map → Properties

Projection: modify according to preference



Map improvement

Í Right-click on map → Properties

Layers: bathymetry + coastlines



Map improvement

Í Right-click on map → Properties

Domain: adjust limits (already done)



Map improvement

Í Right-click on map → Properties

Annotations: not necessary



Map improvement

Í Right-click on map → Properties

View → Layout template → Full Screen Map F8



Station window

View → Layout template → Station window



Station window

View → Layout template → Station window



Station window

Enter



Station window

Í Right-click on map:
Change X and Y variable (salinity vs. depth)
Y variable → Check the reverse range box



Station window

Double click on the map (left) to get profiles at different locations

B Very different properties according to the basin

� Maybe needed to adjust range, otherwise not visible



Station window

Compare profiles in different sub-regions

� To remove stations: Manage Pick List → Remove all Stations



Station window

What happens with this profile south of Cyprus?



Station window

What happens with this profile south of Cyprus?

B Mixed-layer depth



Surface window

Define new isosurface variables:
View → Isosurface Variables → salinity at depth = 0
Click on ”Add”



Surface window

Define new isosurface variables:
Same at depth = 200



Surface window

View → Layout Template → SURFACE Window



Surface window

Í Right-click Z-variable → select newly created variable

B higher salinity values in the Eastern Basin

� Adapt the range for the selected variable



Surface window

Also possible to have several Surface Windows



Surface window: quality flag

View → Isosurface Variables → Quality flag on interpolated variable
at depth = 0



Surface window: quality flag

Quality flag: integer value reflecting the confidence in the
observations



Surface window: quality flag

CORA Quality flags:

1 good
2 rather good
3 quite good
4 acceptable
5 bad quality interpolation

6, 7, 8 not used
9 not interpolated

� ODV definitions for the flags are different!



Surface window: quality flag

Í Right-click Sample Selection Criteria → Quality → Accepted
quality flags = 1



Surface window: quality flag

Í Right-click Sample Selection Criteria → Quality → Accepted
quality flags = 1

B higher salinity values in the Eastern Basin



Surface window: gridding

View → Layout Template → SURFACE Window (× 2)



Surface window: gridding

Set Z variable to be Salinity at 0 m



Surface window: gridding

Í Right-click Properties → Display style → Gridded →
Weighted-Average gridding (default parameters 20 X 20)



Surface window: gridding

Gridded field of salinity

� Normal interpolation does not consider boundaries!



Surface window: gridding

Change Griddin method to DIVA Gridding



Surface window: gridding

DIVA gridded field of salinity

� Field with error above threshold is masked

B Interpolation technique is crucial with in situ data



Section window

View → Layout Template → SECTION Window



Section window

Í Right-click Manage Section → Define Section
Draw line along section



Section window

Edit Section Properties



Section window

Change X, Y and Z variables
→ Distance, Depth and Salinity



Section window

Set Z range between 0 and 500 m



Section window

Grid using DIVA interpolation



Scatter window

View → Layout Template → SECTION Window



Scatter window

Change X, Y and Z variables

B Usually: Salinity vs. Temperature (T-S diagram)



Scatter window

Scatter plot: Salinity, Depth and Longitude

B Lower salinity near Atlantic



Working on data
using Python



What is an ipython notebook?

Python: high-level programming language
https://www.python.org/

IPython: command shell for interactive computing
http://ipython.org/

IPython notebook: web-based interactive computational environment
combining code, text, figures, . . .
http://ipython.org/notebook.html

https://www.python.org/
http://ipython.org/
http://ipython.org/notebook.html
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How to get the code?

The code is made available through github:
https://github.com/ctroupin/OceanData NoteBooks

1. Download the zipped archive on your computer
(in ˜/CMEMS_INSTAC_Training)

2. Extract the archive
u n z i p OceanData NoteBooks−m a s t e r . z i p

3. Go in the main directory
cd ˜ / CMEMS INSTAC Training / OceanData NoteBooks−m a s t e r /

https://github.com/ctroupin/OceanData_NoteBooks
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How to get the code?

1. Download the zipped archive on your computer
(in ˜/CMEMS_INSTAC_Training)

2. Extract the archive
u n z i p OceanData NoteBooks−m a s t e r . z i p

3. Go in the main directory
cd ˜ / CMEMS INSTAC Training / OceanData NoteBooks−m a s t e r /



How to run a notebook?

1. Download the zipped archive on your computer
(in ˜/CMEMS_INSTAC_Training)

2. Extract the archive
u n z i p OceanData NoteBooks−m a s t e r . z i p

3. Go in the main directory
cd ˜ / CMEMS INSTAC Training / OceanData NoteBooks−m a s t e r /

4. In a terminal, type
i p y t h o n no tebook R e a d T i m e S e r i e s 1 . ipynb



How to run a notebook?

1. Download the zipped archive on your computer
(in ˜/CMEMS_INSTAC_Training)

2. Extract the archive
u n z i p OceanData NoteBooks−m a s t e r . z i p

3. Go in the main directory
cd ˜ / CMEMS INSTAC Training / OceanData NoteBooks−m a s t e r /

4. In a terminal, type
i p y t h o n no tebook R e a d T i m e S e r i e s 1 . ipynb

You should obtain something like that:



Structure of a notebook

Run current cell
Add a new cell
Select type of cell
Code cell
Text cell
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Structure of a notebook

Run current cell
Add a new cell
Select type of cell
Code cell
Text cell



Structure of a repository

In the directory containing the notebooks, type:
i p y t h o n no tebook

You should get:



Structure of a repository

In the directory containing the notebooks, type:
i p y t h o n no tebook

You should get:



What’s inside the repository?

Read TimeSeries 1.ipynb: reading a local netCDF file

Read TimeSeries 2.ipynb: reading a remote netCDF using OPeNDAP protocol
Read TimeSeries 3.ipynb: reading a netCDF using the CF module

Read drifter data 1.ipynb: basic plot of a drifter trajectory
Read drifter data 2.ipynb: plotting temperature observations from drifters
Read drifter data 3.ipynb: gridding temperature observations from drifters

Plot TimeSeries1.ipynb: plotting temperature from a mooring
Read CORA dataset.ipynb: reading and plotting data from CORA dataset

http://www.unidata.ucar.edu/software/netcdf/
http://www.opendap.org/
http://cfpython.bitbucket.org/
http://www.ocean-sci.net/9/1/2013/os-9-1-2013.pdf


What’s inside the repository?

Read TimeSeries 1.ipynb: reading a local netCDF file
Read TimeSeries 2.ipynb: reading a remote netCDF using OPeNDAP protocol

Read TimeSeries 3.ipynb: reading a netCDF using the CF module

Read drifter data 1.ipynb: basic plot of a drifter trajectory
Read drifter data 2.ipynb: plotting temperature observations from drifters
Read drifter data 3.ipynb: gridding temperature observations from drifters

Plot TimeSeries1.ipynb: plotting temperature from a mooring
Read CORA dataset.ipynb: reading and plotting data from CORA dataset

http://www.unidata.ucar.edu/software/netcdf/
http://www.opendap.org/
http://cfpython.bitbucket.org/
http://www.ocean-sci.net/9/1/2013/os-9-1-2013.pdf


What’s inside the repository?

Read TimeSeries 1.ipynb: reading a local netCDF file
Read TimeSeries 2.ipynb: reading a remote netCDF using OPeNDAP protocol
Read TimeSeries 3.ipynb: reading a netCDF using the CF module

Read drifter data 1.ipynb: basic plot of a drifter trajectory
Read drifter data 2.ipynb: plotting temperature observations from drifters
Read drifter data 3.ipynb: gridding temperature observations from drifters

Plot TimeSeries1.ipynb: plotting temperature from a mooring
Read CORA dataset.ipynb: reading and plotting data from CORA dataset

http://www.unidata.ucar.edu/software/netcdf/
http://www.opendap.org/
http://cfpython.bitbucket.org/
http://www.ocean-sci.net/9/1/2013/os-9-1-2013.pdf


What’s inside the repository?

Read TimeSeries 1.ipynb: reading a local netCDF file
Read TimeSeries 2.ipynb: reading a remote netCDF using OPeNDAP protocol
Read TimeSeries 3.ipynb: reading a netCDF using the CF module

Read drifter data 1.ipynb: basic plot of a drifter trajectory

Read drifter data 2.ipynb: plotting temperature observations from drifters
Read drifter data 3.ipynb: gridding temperature observations from drifters

Plot TimeSeries1.ipynb: plotting temperature from a mooring
Read CORA dataset.ipynb: reading and plotting data from CORA dataset

http://www.unidata.ucar.edu/software/netcdf/
http://www.opendap.org/
http://cfpython.bitbucket.org/
http://www.ocean-sci.net/9/1/2013/os-9-1-2013.pdf


What’s inside the repository?

Read TimeSeries 1.ipynb: reading a local netCDF file
Read TimeSeries 2.ipynb: reading a remote netCDF using OPeNDAP protocol
Read TimeSeries 3.ipynb: reading a netCDF using the CF module

Read drifter data 1.ipynb: basic plot of a drifter trajectory
Read drifter data 2.ipynb: plotting temperature observations from drifters

Read drifter data 3.ipynb: gridding temperature observations from drifters

Plot TimeSeries1.ipynb: plotting temperature from a mooring
Read CORA dataset.ipynb: reading and plotting data from CORA dataset

http://www.unidata.ucar.edu/software/netcdf/
http://www.opendap.org/
http://cfpython.bitbucket.org/
http://www.ocean-sci.net/9/1/2013/os-9-1-2013.pdf


What’s inside the repository?

Read TimeSeries 1.ipynb: reading a local netCDF file
Read TimeSeries 2.ipynb: reading a remote netCDF using OPeNDAP protocol
Read TimeSeries 3.ipynb: reading a netCDF using the CF module

Read drifter data 1.ipynb: basic plot of a drifter trajectory
Read drifter data 2.ipynb: plotting temperature observations from drifters
Read drifter data 3.ipynb: gridding temperature observations from drifters

Plot TimeSeries1.ipynb: plotting temperature from a mooring
Read CORA dataset.ipynb: reading and plotting data from CORA dataset

http://www.unidata.ucar.edu/software/netcdf/
http://www.opendap.org/
http://cfpython.bitbucket.org/
http://www.ocean-sci.net/9/1/2013/os-9-1-2013.pdf


What’s inside the repository?

Read TimeSeries 1.ipynb: reading a local netCDF file
Read TimeSeries 2.ipynb: reading a remote netCDF using OPeNDAP protocol
Read TimeSeries 3.ipynb: reading a netCDF using the CF module

Read drifter data 1.ipynb: basic plot of a drifter trajectory
Read drifter data 2.ipynb: plotting temperature observations from drifters
Read drifter data 3.ipynb: gridding temperature observations from drifters

Plot TimeSeries1.ipynb: plotting temperature from a mooring

Read CORA dataset.ipynb: reading and plotting data from CORA dataset

http://www.unidata.ucar.edu/software/netcdf/
http://www.opendap.org/
http://cfpython.bitbucket.org/
http://www.ocean-sci.net/9/1/2013/os-9-1-2013.pdf


What’s inside the repository?

Read TimeSeries 1.ipynb: reading a local netCDF file
Read TimeSeries 2.ipynb: reading a remote netCDF using OPeNDAP protocol
Read TimeSeries 3.ipynb: reading a netCDF using the CF module

Read drifter data 1.ipynb: basic plot of a drifter trajectory
Read drifter data 2.ipynb: plotting temperature observations from drifters
Read drifter data 3.ipynb: gridding temperature observations from drifters

Plot TimeSeries1.ipynb: plotting temperature from a mooring
Read CORA dataset.ipynb: reading and plotting data from CORA dataset

http://www.unidata.ucar.edu/software/netcdf/
http://www.opendap.org/
http://cfpython.bitbucket.org/
http://www.ocean-sci.net/9/1/2013/os-9-1-2013.pdf


Example: plotting a time series

Notebook file: Plot TimeSeries1.ipynb

Product: Mediterranean Sea near real-time observations
(INSITU MED NRT OBSERVATIONS 013 035)

Data file: IR TS MO 61198.nc Mooring managed by Puertos del Estado (Spain)

Objectives: 1. Read a netCDF file
2. Apply the quality flags to the observations
3. Generate high-quality plot
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